Back to overview
Downtime

All sites down

Oct 10 at 06:35am CDT
Affected services
Platform
Customer Portal

Resolved
Oct 10 at 07:02am CDT

Issue resolved

Updated
Oct 10 at 06:41am CDT

We have identified the root cause of the issue and the primary platform has been placed back online. The customer portal will come back online shortly

Created
Oct 10 at 06:35am CDT

An unknown routing incident is underway. All websites are currently down until further notice.